PDA

View Full Version : Computer genius required! [MS Access 2007 help needed]


!xobile
02-17-2009, 02:00 AM
So im creating a database in MS Access 2007. I creat a table with the heading 'Membership Number' I want it so that if i type a number (in the form) with more then 7 digits, a message appears. Don't know the rule to apply in the validation rule if it even goes there.

+rep to whoever help me.

EDIT: I also know that you can password lock the database. Anyone know how to do this.

Pyros
02-17-2009, 02:13 AM
I dont have an answer as I've never ever ever used Microsoft Access... however, do you mind if I changed the title of your thread to "microsoft access help? it might give ya a better chance of getting some answers

Pyros

esteem
02-17-2009, 06:28 AM
validation rule: <10000000
validation text: your message to display

That's if it is actually a positive number.

You could also do:
Like "???????" OR Like "??????" OR Like "?????" OR Like "????" OR Like "???" OR Like "??" OR Like "?"

They're not perfect solutions but one should work.

For the password go to the tools menu, select security then "set database password".

!xobile
02-17-2009, 06:58 AM
Thanks +rep but i have a new problem. I was playing about with the database trying to put a password on it but something happened and know i cant open it. I get the message "You do not have the necessary permissions to use the <pathway> object. Have your system administrator or the person who created this object establish the appropriate permissions for you. (Error 3033)"

I only have 1 user on my computer which is the administrator.

Oh and this is for access 2007

Any ideas on how to fix this?

Jimmy2009
02-17-2009, 07:01 AM
You must of enabled the password feature and forgot the password, if this is what you did. It's a common problem but you'll be locked out of the database for good, you'll have to create a new one...

!xobile
02-17-2009, 07:04 AM
i remember the password but there is no place to enter it. I just get the error message, click ok and a blank database.

Jimmy2009
02-17-2009, 07:06 AM
Hmm, not sure then...Only way i could really work out with whats up with it is actually going on the database its self but thats impossible to do lol
Sorry i can't help any more :sad:

!xobile
02-17-2009, 07:07 AM
i cant send u a copy

Jimmy2009
02-17-2009, 07:13 AM
i cant send u a copy

Just try playing about with all the settings etc, that sometimes works

!xobile
02-17-2009, 07:16 AM
trust me ive tried that for about an hour know. Do u want a copy so u can try?

esteem
02-17-2009, 07:17 AM
Log in to the database and give permissions for all objects back to the Users Group.

Open Access using the default system.mdw workgroup e.g. start > run > "C:\Program Files\Microsoft Office\Office\Msaccess.exe" /wrkgrp "C:\Secure.mdw" , start a new database, and import all the objects from your old database.

I don't see the +rep?

Jimmy2009
02-17-2009, 07:17 AM
trust me ive tried that for about an hour know. Do u want a copy so u can try?

Yer you could send me one, PM me

!xobile
02-17-2009, 07:29 AM
esteem, admin made it so that the user cannot see there own rep. Also the thing u told me doesn't work, shall i send u a copy aswel so u can try?

!xobile
02-17-2009, 07:41 AM
jimmy check ur PM